«

»

Apr 07

Citrix XenServer, meh. Console Access, neat!

Recently I have performed some discovery and analysis on a couple of production Citrix XenServer environments. Both of them hosting Citrix XenDesktop and both of them have been running beside a VMware vSphere environment. Not sure exactly why the design decision was made to introduce a separate hypervisor to an environment when XenDesktop is fully supported on VMware but what is done is done.

One of these environments is going through a network redesign and I am helping out with that. The network changes are going to require that some changes be made to the network configurations on the XenServers and this is what I was asked to help out with. I have had minimal exposure to XenServer and it was back a few years ago so I needed a quick refresh. I spun up XenServer in the lab for some quick testing.

XenCenter-ScreenShot

Good news is the changes that need to be made are fairly simple and things should go without issue. Bad news is all VMs without XenServer Tools installed (a majority of them) will have to be powered down before the network connection can be changed. What!!! Powered down to disconnect a VM from one network and reconnect it to a different one, yep. Crap!

One feature of XenCenter that I do find extremely neat (and useful) is the host Console access through XenCenter. Just select the host and then the Console Tab and you are presented with a command line console for the select XenServer host.

XenCenter-CLIConsole

To start up the console GUI (similar to DCUI on ESXi) run xsconsole from the command line.

XenCenter-GUIConsole

XenServer was easy to install and XenCenter management is fairly intuitive. The host console access is a neat feature but overall I am not impressed (now I know why I stopped messing with this way back when). I am going to keep poking around in it just so I can be familiar with the ins and outs but as I tweeted yesterday – “XenServer installed in the home lab. So I tried it and it is OK, now give me back my vSphere.”

BTW my lab XenServer environment is running on ESXi. To do this you prepare and configure the VM just as you would to run nested ESXi (VM HW version 9, vhv.enabled = “TRUE”, and Guest OS: VMware ESXi 5.x).

XenonESXi

I <3 vSphere!

About the author

vHersey

Hersey Cartwright is an IT professional with extensive experience designing, implementing, managing, and supporting technologies that improve business processes. Hersey is Solutions Architect for SimpliVity covering Virginia, Washington DC, and Maryland. He holds the VMware Certified Design Expert (VCDX-DV #128) certification. Hersey actively participates in the VMware community and was awarded the VMware vExpert title in 2016, 2015, 2014, 2013, and 2012. He enjoys working with, teaching, and writing about virtualization and other data center technologies. Follow Hersey on Twitter @herseyc

1 comment

  1. Shawn Mulligan

    Hi there,

    Well I was kinda hoping you can help me out of a bind. I have a server running xenserver on, I somehow while on my windows machine decided to accidentally detach a local drive to a vm. I then reattached the drive to the vm and now the system will not boot. Or it will boot I should say but nothing loads by domain / ip address.

    Being I am running ASL core, I can not go to the console to see what is happening first hand. Maybe services are not started or something.

    I guess the real question is do you just detach and then attach? Or is there more to it? I have tried alot of different things but am not sure as to what the issue is. I can’t even get to runlevel 1. I hope that I don’t have to setup the vm from scractch again, and have to install all the software needed and then restore from backup.

    thanks for any input.
    Shawn Mulligan

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

6 + four =